... by: ThosInt the description of remote pairs (paragraph 2, line 6) you say "MUST occur in both squares." which is not allowed as only one digit may appear in a square. Perhaps you meant "MUST both occur in these two squares."
P.S. I still prefer to call an individual position a "cell" as there are some who use" square" to refer to a 3 x 3 block. aand "cell" is unambiguous.
P. P. S. You often reject a correctly typed security code although the second try is usually accepted but not always.
Andrew Stuart writes:
Yes, I prefer your wording in that phrase so I've changed it. I also agree with the idea of cells instead of squares. This is a particularly ancient piece of text but easy enough to amend.